Author Topic: No Turn Signals or BRakE Lights  (Read 2143 times)

0 Members and 1 Guest are viewing this topic.

Offline ShaneInsane

  • Newbie
  • *
  • Posts: 5
No Turn Signals or BRakE Lights
« on: October 22, 2008, 12:06:32 AM »
I have no turn signals or brake lights on my 1990 Dodge Ram Charger. . 
I have checked the bulbs, fuses, don't know what else it could be besides the wiriing. .

Offline 340SHORTY

  • Sr. Member
  • *****
  • Posts: 4098
  • Gender: Male
  • on a steep hill
Re: No Turn Signals or BRakE Lights
« Reply #1 on: October 22, 2008, 12:38:26 AM »
replace the turn signal switch.... {beer}
Your truck info goes here...

Offline 3jvj

  • Sr. Member
  • *****
  • Posts: 4817
  • Gender: Male
  • I like snow. In July.
Re: No Turn Signals or BRakE Lights
« Reply #2 on: October 22, 2008, 01:27:57 AM »
replace the turn signal switch.... {beer}
X2

Pull your steering wheel and start swappin.  You should take notes and pics so we can enjoy it as well. ;D
74 power wagon swb 440/435/205 Forest Circus Green
01 Durango 5.9
73 fj55
63 fj40

Blah, blah, blah; Obama. ::)

Offline wevie

  • Jr. Member
  • ***
  • Posts: 885
  • Gender: Male
  • RCC Rules!
Re: No Turn Signals or BRakE Lights
« Reply #3 on: October 22, 2008, 02:14:54 AM »
STOP

Before you tear anything apart. . .

Triple check and make sure the hazard switch is pulled out (off).  I haven't had this on my RC, but on other dodge vehicles from the 80's the hazards are on a flasher of their own and when activated, the turn signals and brake lights are deactivated.
1984 RC, 5.9L, 4x4, cam and headers

Online DODGEBOYS

  • DODGEBOYS.NET / RCC Signiture Police
  • RCC Addict
  • ********
  • Posts: 22414
  • Gender: Male
  • show me the Flame and l might see the light
    • DODGE TRUCKS @ DODGEBOYS.NET
Re: No Turn Signals or BRakE Lights
« Reply #4 on: October 22, 2008, 05:47:24 AM »
l can send you the pin-out wiring diagram to check the blinker switch
put your truck info HERE
MOPAR TO YA! AARON HOWORD TOWNSEND / SLANTEDMIND---GOD BLESSDODGEBOYS FSM STORE
ramchargercentral@hotmail.com
DO NOT use the site IM,s to contact me  l have them turned OFF

Offline jsmith10

  • RCC Rookie
  • **
  • Posts: 361
  • Gender: Male
  • Its not broken....... Its custom.
Re: No Turn Signals or BRakE Lights
« Reply #5 on: October 22, 2008, 02:32:59 PM »
Hey, the same thing happens to mine sometimes. im not sure what it is but they go out, then start working seemingly without any rhyme or reason. Good luck, Josh
1979 Ramcharger Prospector<br />360<br />rv cam<br />aluminum intake<br />edelbrock 650<br />tourquflite 727<br />203 t-case<br />more to come when I win the lottery :)

Offline barracudadave67

  • Newbie
  • *
  • Posts: 147
  • Gender: Male
  • Firstest with the Mostest or I gotta lotta mopars
Re: No Turn Signals or BRakE Lights
« Reply #6 on: October 23, 2008, 10:13:37 AM »
If the RC is equipted with an "multifunction switch", this could be the culprit,they are easy to disassemble. They are printed circuits with electric grease as a lube, and over the years this dries up and messes up the functions of the sw. I have had two of them, that the blinkers would not work properly sometimes and that affects the tail lights, also. I found this out after months of trouble shooting the blinkers and tail lights. My wifes 96 Dodge van had the same problem with her wipers (part of the MF SW)

If the MF SW is the Problem, remove it from steering coloum, dissassemble it ,and clean it with "Electronic Cleaner", (not brake cleaner), regrease the contacts on the printed circuits, with a good synthetic grease, and reassemble. This process worked on my two RCs, and my wifes van.

If all else fails check the MF SW out. They are easy to fix. New ones from Mopar are (I think), $150.00
They are the same for many years.

Hope this helps

dave C. aka barracudadave67
91-RC-318-TBI-4X4-Bench Seat (restored)
69-B-CUDA-FB-340-4bbl-904-8 3/4-323
67-B-CUDA-NB-273-4bbl 904-8 3/4-323
66-Dart-GT-273-Project car-8 3/4
04-RAM-1500-4x4-5.7 Hemi
99-Ram -1500 --5.9-4x4- Daily driver

Offline 340SHORTY

  • Sr. Member
  • *****
  • Posts: 4098
  • Gender: Male
  • on a steep hill
Re: No Turn Signals or BRakE Lights
« Reply #7 on: October 23, 2008, 02:17:58 PM »
If the RC is equipted with an "multifunction switch", this could be the culprit,they are easy to disassemble. They are printed circuits with electric grease as a lube, and over the years this dries up and messes up the functions of the sw. I have had two of them, that the blinkers would not work properly sometimes and that affects the tail lights, also. I found this out after months of trouble shooting the blinkers and tail lights. My wifes 96 Dodge van had the same problem with her wipers (part of the MF SW)

If the MF SW is the Problem, remove it from steering coloum, dissassemble it ,and clean it with "Electronic Cleaner", (not brake cleaner), regrease the contacts on the printed circuits, with a good synthetic grease, and reassemble. This process worked on my two RCs, and my wifes van.

If all else fails check the MF SW out. They are easy to fix. New ones from Mopar are (I think), $150.00
They are the same for many years.

Hope this helps

dave C. aka barracudadave67




 {ttiwwop}
Your truck info goes here...

Offline 79 Hot Rod RC

  • Newbie
  • *
  • Posts: 30
  • Gender: Male
  • RCC Rules!
Re: No Turn Signals or BRakE Lights
« Reply #8 on: October 29, 2008, 12:34:05 PM »
I just recently went through this in my 79 RC and it turned out that the lug on the bottom of the fuse panel that powers the turn signals, brake lights, and interior dome light was shorting out intermittently across another wire.  It is a pain to see as the panel on the early RCs is up in the top of the dash and this is all underneath it.  I had to use a mirror to see it.  Once I moved wires around, the problem went away.

Offline 77Utiline

  • Newbie
  • *
  • Posts: 13
  • Gender: Male
  • RCC Rules!
Re: No Turn Signals or BRakE Lights
« Reply #9 on: October 30, 2008, 09:38:44 AM »
replace the turn signal switch.... {beer}
Most likely this is the problem but also make sure your horn lead isn't touching the switch or the column. I had the same problem about a year ago, replaced the switch and haven't had a problem since.

Offline drake13

  • Newbie
  • *
  • Posts: 22
  • Gender: Male
Re: No Turn Signals or BRakE Lights
« Reply #10 on: October 30, 2008, 07:23:53 PM »
My problem is my brake lights and signals work....but when the headlights are on they dont? Actually they work but when I dont touch them they dont. If i am sitting in my driveway with the lights on, I have no running lights? Any ideas?

Offline drake13

  • Newbie
  • *
  • Posts: 22
  • Gender: Male
Re: No Turn Signals or BRakE Lights
« Reply #11 on: November 3, 2008, 09:12:07 PM »
anybody?